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Using Crystal Reports with Lucity 
Beginner Examples – 2  

The second of a seven-part series, this workbook is designed for new Crystal Reports® users.  You’ll 
learn how to add selection parameters to a report including date ranges, secured fields, and selection 
categories.  We’ll also show you how to sort and group the report data.  Finally, we’ll show you how to 
add summaries and running totals to a report.   

 

The screen captures in this workbook are taken from Crystal XI.  Depending on which version of Crystal 
you are using, your screens may vary slightly. 
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Section Options 
Each section of the report has a variety of options available to it.  To view these options, right click in 
each section to the left of the report.   

o Some useful options include Suppress, Hide, Insert Section Below, Delete Section, and Select 
All Section Objects.  The availability of the options depends on the section. 

 

Section Expert 
The Section Expert can be accessed from the above right click menu or at the top of the report in the 
Expert Toolbar or under Report in the Menu Bar.   

1. Click on Section Expert .  You’ll see the following dialog:   
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Some options that have been chosen elsewhere, such as Suppress, are reflected here.  Other useful 
options include conditional suppression of a section (using the Suppress formula button), New Page 
After, Keep Together, Suppress Blank Section (used for sub-reports), and Format with Multiple 
Columns (Details section only). 

Formatting Multiple Columns 
You may want to format a report with multiple columns.  This is set up with the information in the 
Details section of the report and may also include the Group section data.   To set up Multiple 
Columns, complete the steps below: 

1. Export the Summary of Request (ReqSum.rpt) report and rename it to LC_ReqSumCol.rpt.   

o Remember, we discussed how to Export a report in our related workbook, Beginning 
Crystal 1. 

2. Reduce the number of columns to two or three.  Keep the Request #, Record Date, and Status 
fields.   

3. Click on Section Expert and choose Details.  If you have multiple Detail sections then you must 
click on the top Details title (not Detail a) and all of the Detail sections will be duplicated.  
Individual Detail sections do not have the Format with Multiple Columns option. 

4. Click on Format with Multiple Columns.  Note the addition of the Layout tab below: 
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5. Click on the Layout tab.   

o You must enter a size for the column section in the Detail Size.  Figure out how wide 
the first set of columns are from the ruler at the top and then allow at least that much 
for the duplicate section. 

o The Horizontal Gap is the space between the columns. 

o The Vertical Gap is the space between each line.   

o It is also important to choose a Printing Direction.   

o Click OK when you have finished altering the layout. 

 

   

Note: The “Format Groups with multiple column” option at the bottom of the Layout tab 
allows this to be used in Grouping (discussed later). 

 

6. The Multiple Column option is not available in the Header section.   

o In order to identify your columns in the header, you’ll need to type in the column 
headings manually.  Or, you can copy and paste them from the report.   

o The Landscape orientation is no longer necessary. 

 Shorten the Lines to 4”. 

 Move the Print Date and Print Time right edges to 8”. 

 In File > Page Setup… >  Orientation select Portrait. 

 OK 

 Below, you can see examples of the report Design and Preview. 

Design 
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Preview 

 

Additional Options 
Right click in the main body of the report or Ruler to find additional options.  These help with the 
report design.   

2. These include Snap to Grid, Remove All Vertical Guidelines and Remove All Horizontal 
Guidelines.  Ruler, Guidelines, Grid, and Tooltips can be accessed through View in the top 
Menu Bar. 

   

Parameters 
Parameters are useful in creating reports that are more dynamic.  The report will query the user for 
information and then typically use this in the record selection criteria. A common use of this feature is 
date ranges, categories and personnel. 

Selection criteria are usually filtered on from within the Lucity modules.  The report is then run using 
these criteria, and the specific criteria used can be stated in the subtitle.  Sometimes, it is helpful to 
have the report make the selection.  In the steps below, we’ll show you how to set up these selection 
parameters in the report. 

Date 
In general it is best to set up a date range with two parameter fields.  The report query will ask the 
user to supply a Start Date and an End Date. 

1. In this example, export the Summary of Request (ReqSum.rpt) report and call it 
LC_ReqSumDt.rpt. 

2. In LC_ReqSumDt.rpt open Field Explorer > Parameter Fields.   

3. Right click on Parameter Fields and select New. 

OR 

Click on Parameter Fields and then click the new icon  in the Field Explorer toolbar. 
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4. In the Create New Parameter dialog, include the following (screen shown on next page): 

o Enter a Name.  For our example, we’ve typed Start Date. 

o Select the type of data that the parameter field will be.  In our example, we will 
choose Date.   

Note: There is an option for DateTime which would correspond with our field type but in the 
report we have pulled the Date portion out of the field using the Date formula.  If you had 
used the DateTime type then the user would have to enter the irrelevant Time portion of 
the field each time they ran the report. 

o Under Options the Prompt Text is automatically filled in with Enter (Parameter 
Name).  This prompting text can be revised by clicking in the box and adding or 
subtracting text.  (We have added “for Status Date Range”.) 
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5. Repeat this procedure for End Date. 

6. There are now two parameter fields (Start Date and End Date) that can be used in the 
selection criteria and in a date title. 

Note:  Even though the parameters have been created, the report will not use them unless 
they are put in the selection criteria. 

 

Record Selection with Parameters 
To use your newly defined Date parameters in a report to select records, complete the followings: 

1. Click on Select Expert   

2. Click the Status Date Formula (StatDate). 

3. Select OK. 
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The dialog displayed below will appear: 

  

4. Select from the drop down boxes the appropriate criteria: 

  

 

5. Then, if you would like to view the formula for the Selection Criteria that you have created, 
click on Show Formula>>> 
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Note:  In Crystal XI there is an option to Set Parameter Order when you right click on 
Parameter Fields in Field Explorer.  This is the order in which you will be queried.  You can 
click and drag the parameters (or use the arrows) to the correct order. 

 

 

 

Adding Parameters to the Report Title 
Once you’ve added Date parameters to a report, you’ll want to add that data to the title section.  This 
helps you know which dates are reflected in the report. 

You can manually enter the dates in the Report Subtitle parameter query. 

OR 

You can create a Formula to automatically state the dates selected and place in the Title section. 

OR 

You can create a Text Object and bring in the dates. 

   Formula Option 
1. Right click on Formula Fields and select New.   

2. Enter a descriptive name.  For our example, we’ve typed “Status Date Range Title”. 

3. Select OK, then type in the following: 
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o "Status Dates Between "&{?Start Date}&" and "&{?End Date} 

o The parameter fields can be selected from the Report Fields. 

4. Now, either remove the Report Subtitle or create some room in the Page Header section to 
drag the @Status Date Range Title formula into the Page Header. 

   

 

 

 

   Text Object Option 
1. Click on Insert Text Object and place below ?Report Subtitle. 

2. Type “Status Dates Between  and ” 

3. Increase the box size to accommodate the addition of the Date parameters. 

4. From Field Explorer > Parameter Fields, drag the Start Date in front of “and” and the End 
Date behind “and”.  Add spaces as needed. 
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Secured Fields  
Sometimes, fields should be hidden in reports if the person viewing the report does not have the proper 
level of security.  This can be done by using parameters and formatting options. Any field can be set up 
for security, such as cost, addresses, or phone #’s. 

Note:  This will only work for fields in the main body of the report.  Fields that need to be 
hidden in subreports will be addressed in our related workbook, Intermediate Crystal 1. 

Many cost fields in Work Order reports are set to use the “Hidden” option.  Sometimes you may wish to 
suppress the fields completely. 

The following steps are provided so you can set up your own field security (step 7). 

1. From  Work > Work Flow Setup > Employees module, export the Employee List Report 
(EmployeeList.rpt) and call the new version LC_EmployeeCost.rpt. 

2. Modify the Department text object to Unit Cost. 

3. Add a text object to the right called Overtime Rate. 

4. Remove the EM_DEPT_TY field. 

5. Add from the WKUEMP table the EM_UNIT_C field beneath the Unit Cost heading. 

6. Add from the WKUEMP table the EM_OVERI_C field beneath the Overtime Rate heading. 

7. Right click Parameter Fields and select New.   

o Type in the Name - ViewSecuredFields.   

 This is a special parameter field that must have this name “ViewSecuredFields”.          
When the report is run within Lucity the security is passed to the report and will 
not query the user.  If the report is run outside of a Lucity module, in Crystal, then 
the security will be queried. 

 If the report is refreshed, it will ask for the parameters again, including the 
permission to view the secure fields.  At this point you can change the security 
value the report will run with. 

o Select the Type > Number and under Options > Discreet Value -True.  

o  Click OK.   

Field Viewing Options 

 Field to Show Blank 

For a blank field to show up when the user does not have rights to view the secured fields, do 
the following:  

o Right click the field that requires suppression (EM_UNIT_C) and select Format Field.   

o Click the Common tab.   

o Click the formula box  next to Suppress.  
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o Double click the ViewSecuredFields parameter from the Report Fields.   

o Type “= 0”. 

{?ViewSecuredFields} = 0 

o Click Save and close. 

o Click OK 

  Field to show “Hidden”  

For the word “Hidden” to show up when the user does not have rights to view the secured 
fields, do the following:  

o Right click in the field that requires suppression (EM_OVERI_C) and select Format 
Field. 

o Click the Common  tab 

o Click the formula box  next to Display String. 

o Type in: 

if {?ViewSecuredFields}=0 then "Hidden" else "$"& totext({WKUEMP.EM_OVERI_C}) 

Note: The inclusion of the dollar sign is because once the formula brings in the word 
“Hidden”, the formula requires the outcome to be text.  The field will not allow number 
formatting.  That is also the reason for the conversion of the EM_OVERI_C field to text. 

o Click Save and Close. 

o Click OK 

If the user did not have permission to view Employee costs then because of the field 
set ups, the Unit cost is blank and the Overtime is showing “Hidden”. 

   

It would be helpful to make a notation at the bottom of the report to explain why some of the fields 
are “Hidden”, such as: 

“A Hidden field indicates permission to view the secured field is turned off.” 

Logged in User ID and Logged in Employee Code – Web Only 
Much like the “ViewSecuredFields” parameter, the Logged in User ID and Logged in Employee Code can 
be brought into the report straight from Lucity.  This is a new enhancement for version 7.4.  This 
information is being brought in from the Employee module in Work. 

For the User ID, create a new parameter called LOGGEDINUSERID.   

For the Employee Code, create a new parameter called LOGGEDINEMPCODE. 

Both parameters are String type fields. 

Drag the parameter fields into the report.  When the report is run from Lucity, these fields will 
populate with the correct Logged in User information. 
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Static and Dynamic Selections 
A pick list of values to use in a report is possible by using parameter fields.  An example of this use will 
be shown in selecting Categories.   

From Work > Work Flow Setup > Category, export Category with Problem and Task Report 
(CatProbTask.rpt) and save as LC_CatProbTaskCat.rpt.   

o Right click Parameter Fields and choose New.   

o Enter the Name (Category). 

o Enter the Type (String). 

o Choose where the List of Values will come from.  Set up as either a Static Selection or 
Dynamic Selection. 

Static Selections   

This allows selection from a set list of values for a specific field. 

1. Next to “List of Values:” select Static. 

2. Under Value Field select CT_BR_TY (This is the Category text field). 

3. If you want to choose specific Categories to be in your selection list, click Insert .  

4. Click on the down arrow under Value.   

5. Click the Category that you want in your list.   

6. For each additional Category, click on a blank line, and then click on Click here to add item, 
and then click the down arrow for the list.   

 If All the Categories should be in the list, click Actions and choose Append all database 
values.  

 This drop down box is also where you can clear all values in a list. 

7. Under Options you may revise the Prompt Text.  It has automatically placed the Name 
(Category) after Enter. 

8. Under Options place True next to both Allow discreet values and Allow multiple values. 

 The True and False options may be changed by clicking on True (or False) which will 
cause a drop down of True or False to select from. 

9. Click OK. 
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Dynamic Selections 
This allows selection from whatever values are in a specific field at the time the user runs the report. 

For This option to be used with Web reports, the report needs to be developed in Crystal 2008 or later 
and run with the HTML view. 

1. Edit the Category parameter.  Next to List of Values: select Dynamic. 

2. In the Prompt Group Text box enter something helpful so the user knows what field is being 
addressed. 

3. Under Choose a Data Source, select New. 

4. Then Click either Insert or Click here to add item.  Select the field in question. 

5. Edit the Prompt text if desired. 

6. Select Options 

7. OK 
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Note: For Web reports, make sure the Show on (Viewer) Panel option is set for Editable. 
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Using the Selection Parameter 

1. You must now add this selection criterion to the Select Expert. 

  {WKCAT.CT_BR_TY} = {?Category} 

2. When the report is run and the Category parameter is queried, it will appear similar to the 
following example.   

o Below, we have selected a group of Categories by clicking on Curbs.   

 Then shift/click on Engineering  

 Then the > button  

o Individual Categories can be moved by clicking on the Category and then the > button.  

o  All of the Categories can be selected by using the >> button. 

o Another helpful way to select Multiple values is selecting the value then holding the 
control key(Ctrl) down and selecting additional values, then moving these values over 
with one click on the > button. 

o The Remove and Remove All buttons work with the Selected Values: window. 

o OK 
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Dynamic Cascading Prompts 
A dynamic cascading prompt allows the user to choose first one selection criteria and for this chosen 
selection then choosing a second one … 

For a Storm Pump Inspection report a parameter was created to choose a Pump Station and then once 
the station was selected then the pumps were selected from a list of pumps associated with the 
station. 

 

 

The selection criteria within the Select Expert would be set up like this: 

{SMPINSP.PI_NUMBER} = {?Station/Pump - PI_NUMBER} and 

{SMSTATN.PN_NUMBER} = {?Station/Pump - PN_NUMBER} 
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When running the report the following prompt would show up: 

 

Sorting 
Sorting is a simple method to view data in your report in a certain order; ascending or descending.  

Crystal Reports allows sorts within sorts, each sort reflecting its own sort direction.  

If there is grouping in a report (discussed next), the grouping comes first before any field sorting.  Many 
of the work reports have groupings to deal with duplicate records created in filtering so simple sorting 
will not work.  Additional sorting results can usually be accomplished with additional groups. 

We are going to set up a simple sort within the LC_ReqSum.rpt report. The following steps will set up 
a sort on the Category then within Category a sort on the Problem. 

1. Click Record Sort Expert .   

2. Choose the field to be sorted by.  This is typically found in the Report Fields.   

3. Click on RQ_CAT_TY and move to the Sort Fields box by pressing the > button.  

4.  Then select the Sort Direction: Ascending or Descending. 

5. Repeat this for the RQ_PROB_TY field.  Each field’s Sort Direction is independent of the other 
fields to be sorted on. 
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Interactive Sorting 
To create a report with a choice of sorting, we will export the Summary of Requests (ReqSum.rpt) 
report and rename it LC_ReqSumSort.rpt. 

1. First we will create a Static parameter formula to list what the sorting choices are. 
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2. Using Formula Workshop, create a formula (Sort) to use the correct sorting parameter. 

 

   

 

3. Place this formula in the Detail Section. 

    

 

4. Use the Format Field option to hide the @Sort formula field by Suppressing. 

    

 

5. Place the @Sort formula under Sort Fields: in the Record Sort Expert  . 
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Preview 

The following prompt will appear.  The drop down arrow will show the fields to be sorted by. 

 

 

 

Grouping 
Grouping is a powerful tool and relatively easy to use. It is particularly helpful when creating 
summaries or counts. 

We are going to add a grouping on Problem to the Summary of Requests report. 

 

1. From Work Requests export the Summary of Requests (ReqSum.rpt) report and rename it 
LC_ReqSumProbGr.rpt.   
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2. Change the Report title.  For example, we’ve titled this report: Requests By Problem Report. 

 

 

 

 

 

3. Select Insert Group .  If the field you wish to “Group By” is currently in the report, click on 
it to highlight it and then press the Insert Group button.  It will automatically be grouped on 
the field; however, you may also use the drop down box to select the field to group on 
(RQ_PROB_TY). 

   

 

4. Choose any pertinent options. 
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o Group Header (GH1) and Footer (GF1) sections have been added.   

o The Group #1 Name is the field that this report was grouped by 

 

   

 

Preview 
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The Problem is now being shown twice, once as a Group Header and again as a column, so we will 
eliminate the Problem column. 

We will create a separate section with the column headings (Page Header b) because there is 
currently no room to fit Problem above Request #. (next page) 

 

 

5. On the left-hand ruler, find the spot where you want the break to occur.  It should appear just 
above the column titles. 

Click and hold the mouse over that spot and move the cursor slightly, pull to the right and 
release.  A new break line is formed.  The section with the column titles is Page Header b 
(PHb). 

6. Increase the size of Page Header a by dragging down the bottom line of this section. 

7. Drag the Problem column title above Request # in the Page Header a section. Format bold. 

8. Left align the Group #1 Name field to the Problem text box. 

9. Delete the Problem field (RQ_PROB_TY). 

10. The address formula could be moved over (left side at 6”). 

11. In File > Page Setup…, change from Landscape orientation to Portrait. 
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Preview 

 

Note:  Like when Sorting, Grouping can be nested; a Group within a Group.  If multiple 
groups had been used then they could be switched around by clicking and dragging on the 
sections. 

Summary 
You may want to know the total count of each individual group.  The summary option can be used for 
this purpose. Continue with the LC_ReqSumProbGr.rpt report. 

 

1. Click on the field that you wish to count. (RQ_NUMBER) 

2. Select Insert Summary .  The Insert Summary dialog will appear: 

 The field to summarize (RQ_NUMBER) should already be in the field to summarize.   

3. Select the type of Summary (Count).   

4. Choose the summary location (Group#1) and click OK.  
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There is now a subtotal for each Problem group.   

o You may want to add some lines and make the group subtotal bold for easier reading. 

 

 

Preview 
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The report already has a Grand Total but if you needed to create one you could repeat the process and 
choose Grand Total (Report Footer) in the Summary location box. The summaries will automatically be 
dropped into the report wherever Crystal seems to think it should go. Click and drag the field and 
reformat it to fit your needs. 

Running Totals 
The Running Totals feature is used to add a list of numbers cumulatively.  The various options offered 
within the Running Total dialog have rendered the use of variables (discussed in later documents) 
obsolete in some cases.   

In this example we will create a count on the number of Work Orders per Category.   

1. In the Work Order module export the Work Order summary Report (WOSum.rpt) and rename 
it LC_WOSumRunTot.rpt.   

2. Create a new group on Category (WO_CAT_TY).   

3. Shift the Category group to Group 1 by clicking and dragging it into position. 

4. Delete the Category Column. 

5. Change page orientation to Portrait by adjusting field sizes and shifting positions to close up 
space. 

6. Change the Report title to “Work Orders By Category Report”. 

7. Add an additional Group Footer 2 section. 

 Bring in the Total Cost Field (WO_TOTCOST) into the new section. 

 Suppress the section. 

8. Within Field Explorer, right click Running Total Fields and select New.  The Create Running 
Total Field dialog will appear. 

9. Type in a name for the Running Total Name (i.e. WO Count). 

10. Choose the Field to Summarize (WO_NUMBER).   

11. Choose the Type of summary (count). 
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12. Choose how the report will Evaluate the Work Order Number field. 

 On change of group – WO_NUMBER 

13. Choose when to Reset (On Change of Group- WO_CAT_TY). 

14. Then, click OK. 

  

15. Add a text object for a column header (WO #) just to the right of Address. 

 

16. Drag the Running Total formula (WO Count) under the WO # column header into the Group 
footer 1 (GF1) section. 

 The Running Total formulas have a pound sign “#” in front to distinguish it as a Running 
Total type field (#WOCount). 
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We will now add a count of Work Orders greater than $200 per Category.  This will use a formula for 
evaluation. 

17. Within Field Explorer, right click Running Total Fields and select New.  The Create Running 
Total Field dialog will appear. 

18. Type in a name for the Running Total Name (WOCount>200). 

19. Choose the Field to Summarize (WO_NUMBER).   

20. Choose the Type of summary (count). 

21. Choose how the report will Evaluate the WO_NUMBER (Use a Formula). 

 Type in the following formula: 

 {WKORDER.WO_TOTCOST}>200 

Choose when to Reset (On Change of Group- WO_CAT_TY). 

22. Then, click OK. 

  

  

 

23. Create a new column title (# WO > $200) and place it to the left of Total Cost. 

24. Drag the Running Total formula (WOCount>200) into the Group Footer 1 section under the 
#WO >$200 column header. 
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Preview 

 

Work Order Reports 
The importance of using Running Totals and Grouping can’t be stressed enough for 
Work Order reports that have summaries.  

This is only an issue if the report is to be run with a filter on any field that is normaly a grid (child) 
type field such as Location, Task or Resource.  Never assume the report will not be used with a filter. 

Grouping 
In the previous report the Work Order information was placed in the Work Order Number Group Footer 
section. 

If the information had been put in the Detail section and the report run with a filter on a field that is 
normaly a grid type field, then the information in the Detail section would show up as many times as  
the filter is true. 
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In the previous example the WO# 2009-00041 record has the following Resources: 

 

If a Lucity filter had been created to view records that had Employees as Resources (WR_RTYP_CD=1) 
then the report run in Lucity with this filter, the previous report would have looked like this: 

 

The WO# 2009-00041 record shows up twice because there are two Employees in the Resource section. 

The Total Cost and # WO>$200 for the Auxiliary Equipment is also double.  The # WO value is correct 
because we said to evaluate on change of group (WO_NUMBER). 

Running Totals 
The way the report is currently set up, the information is placed in the Work Order Number Group 
Footer section and the Total Cost Field is in a formula with variables (discussed in later documents).  
The Cost field could have been brought in simply as a field (WO_TOTCOST).  Running Totals could have 
been used to total the cost for both the Category Group and the Report Total. 

The following example shows the importance of the Running Total  instead of the Summary  
when the report is run with a filter of a field from a grid. 

The information is placed in the Work Order Number Group Footer section so it only shows once. 

 

 

 

The total cost for the Category is shown with a simple summary in Bold and as a Running Total formula 
in Italic. 
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Concatenate Fields 
Multiple fields can be joined together in a single formula as opposed to bringing all of the fields in 
separately.   

This might be useful for names or address.  The concept is simple; however, if any of the fields in a 
simple “+” type formula are empty, the formula would show up as blank.   

The null fields need to be addressed as follows: 

Two Field Formula 
1. In the current Work Order Detail Report (WODetail.rpt) the Billing information looks like this: 

 

 

 

Preview 

 

 

2. We can create a formula to join the First and Last Names.  In the example we will create a 
formula called Name: 

In the Formula Workshop the formula can be typed in manually or parts can be brought in 
from the various workshop sections (Field, Function or Operator). “If Then Else” can be brought 
from Operators > Control Structure. “Is Null” can be brought in from Functions > Print State. 

 

(If IsNull({WKORDER.WO_BFIRST}) Then " " Else {WKORDER.WO_BFIRST})&" "& 

(If IsNull({WKORDER.WO_BLAST}) Then " " Else {WKORDER.WO_BLAST}) 

o This would change the format to: 

 

 

Preview 
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Address Formula 
Another common usage of concatenated fields is the Address field.  Any time a record shows the 
address as multiple parts ADR_BDG and ADR_DIR then this is a field that uses the address set up in the 
General section of Lucity.  It should be brought into a report as a concatenated formula. 

The Work Order Location Address is as follows: 

(If isNull({WKORDERLOC.WL_ADR_BDG})then "" else 
Trim(ToText({WKORDERLOC.WL_ADR_BDG},0,"","")))+" "+ 

   (If isNull({WKORDERLOC.WL_ADR_DIR})then "" else Trim({WKORDERLOC.WL_ADR_DIR}))+" "+ 

    Trim({WKORDERLOC.WL_ADR_STR})+" "+ 

   (If isNull({WKORDERLOC.WL_ADR_TY}) then "" else Trim({WKORDERLOC.WL_ADR_TY}))+" "+ 

   (If isNull({WKORDERLOC.WL_ADR_SFX}) then "" else Trim({WKORDERLOC.WL_ADR_SFX}))+" "+ 

   (If isNull({WKORDERLOC.WL_ADR_APT}) then "" else Trim({WKORDERLOC.WL_ADR_APT})) 

 

A null Street Name is not addressed because we do not want to see the formula if there is no Street 
Name. 

 


