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Using Crystal Reports with Lucity

Beginner Examples - 2

The second of a seven-part series, this workbook is designed for new Crystal Reports® users. You’ll
learn how to add selection parameters to a report including date ranges, secured fields, and selection
categories. We’ll also show you how to sort and group the report data. Finally, we’ll show you how to
add summaries and running totals to a report.

The screen captures in this workbook are taken from Crystal XI. Depending on which version of Crystal
you are using, your screens may vary slightly.
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Section Options

Each section of the report has a variety of options available to it. To view these options, right click in
each section to the left of the report.

o Some useful options include Suppress, Hide, Insert Section Below, Delete Section, and Select
All Section Objects. The availability of the options depends on the section.

Details

Hide (Dril-Down OK)
Dan't Suppress

Section Expert...

Show Long Section Names

Insert Line
Delete Last Line
Arrange Lines
Fit: Section

Insert Section Below

Select All Section Objects

Section Expert

The Section Expert can be accessed from the above right click menu or at the top of the report in the
Expert Toolbar or under Report in the Menu Bar.

o Click on Section Expert (& . You’ll see the following dialog:

=)

-
Section Expert

Sections: Delete || Mergs | 4 |+ | [ ommon | color
'

Page Header
Dietails

Page Footer
Report Footer

Free-Form Placement
|| Hide {Drill-Down OK)

Suppress (Mo Drill-Down)

[ ] Print at Bottom of Page
Mew Page Before

[ Mew Page After

[] reset Page Mumber After

Keep Together

|| suppress Blank Section

B |08 (0% 0% | (15 0% |B%

[T underlay Following Sections

7| read-only
[ relative Positions

[ OK ][ Cancel ” Help ]
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Some options that have been chosen elsewhere, such as Suppress, are reflected here. Other useful
options include conditional suppression of a section (using the Suppress formula button), New Page
After, Keep Together, Suppress Blank Section (used for sub-reports), and Format with Multiple
Columns (Details section only).

Formatting Multiple Columns

You may want to format a report with multiple columns. This is set up with the information in the
Details section of the report and may also include the Group section data. To set up Multiple
Columns, complete the steps below:

1. Export the Summary of Request (ReqSum.rpt) report and rename it to LC_ReqSumCol.rpt.

o Remember, we discussed how to Export a report in our related workbook, Beginning
Crystal 1.

2. Reduce the number of columns to two or three. Keep the Request #, Record Date, and Status
fields.

3. Click on Section Expert and choose Details.

o If you have multiple Detail sections then you must click on the top Details title (not
Detail a) and all of the Detail sections will be duplicated. Individual Detail sections do
not have the Format with Multiple Columns option.

4. Click on Format with Multiple Columns.
o Note the addition of the Layout tab below:

Camrman | |:

Commat | Colar |

¥ Free-Farm Placement

[ Hide [Dill-Dowen 0K

[T Suppress (Mo Drill-Down)
[ Prirt at Bottom of Page
[~ Mew Page Eefore

[ Mew Page after

[ Reset Page Mumber After
v Keep Together

[ Suppress Blank Section

[ Underlay Following S ections

[ Format with kultiple Colurns

Beginning Crystal 2

¥ Free-Form Placement

[ Hide [Dril-Down OK]

[~ Suppress [Ma Orill-Diown)
™ Print at Bottom of Page
[” Mew Page Before

[ Mew Page &fter

[~ Reset Page Mumber After
¥ Keep Together

™ Suppress Elank Section

[ Underlay Following Sections

@mat with b ultiple @




5. Click on the Layout tab.

a. You must enter a size for the column section in the Detail Size. Figure out how wide
the first set of columns are from the ruler at the top and then allow at least that much
for the duplicate section.

b. The Horizontal Gap is the space between the columns.

c. The Vertical Gap is the space between each line.

d. Itis also important to choose a Printing Direction.

e. Click OK when you have finished altering the layout.

il Section Expert

Sechions:

Inzert | Delete | ferae |+|*|

Feport Header
i |Pane Header

Fage Footer
Repart Footer

Zomman I Color  Lawyout |

— Detail Size:
Width

Height

— Gap Between Details:

i IEI.EIEI:I
Horizontal "
Wertical IEI.EIEIEI "

— Printing Direction:

f+ Across then Down

" Down then Acrozs

[~ Eommat Groups with multiple colurmn

Note: The “Format Groups with multiple column” option at the bottom of the Layout tab
allows this to be used in Grouping (discussed later).

The Multiple Column option is not available in the Header section.

In order to identify your columns in the header, you’ll need to create new column headings or copy the

existing ones and paste.

The Landscape orientation is no longer necessary.

1. Shorten the Line in the Detail section to 4”.

Shorten all other lines to 8”.

Move the Print Date and Print Time right edges to 8”.

OK

Center Page number. Save
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Below, you can see examples of the report Design and Preview.

Design
E T T T S - T -
Reguest # . [ecord Date, Status B Reguest# . [Fecord Date Status
RQ_NUMBER .. @RegDate, RO_STAT_TY N | RQ_NUMBER .. @ReqDaty RQ_STAT_TY
Total Requestsz . ¥TotReq ,
Preview
Summary of Requests 20272014
9:35 AM
Request # Record Date Status Reguest# Record Date Status
2006-00013 4/5/2006 Completed 2006-00022 4/5/2006 Completed

2008-00025 4/5/2008 Completed 2008-00087 4/8/2008 Completed

Additional Options

Right click in the main body of the report or Ruler to find additional options. These help with the
report design.

o These include Snap to Grid, Remove All Vertical Guidelines and Remove All Horizontal
Guidelines. Ruler, Guidelines, Grid, and Tooltips can be accessed through View in the top
Menu Bar.

(& Section Expert...
Show Hidden Sections in Design

ab Insert Text Object
[o] Insert Cross-Tab...
@il Insert Chart...

Remove All Vertical Guidelines
Remove All Horizontal Guidelines
Page Setup...

Snap to Grid

ER Paste

Multiple Reports

To quickly move between multiple reports it can be helpful to view them as multiple tabs. To set up
this design, open your first report in Crystal then select File > Open... and then open the additional
report to be viewed or worked on.

w05um.rpy" WODetail.rpt x

| Design |

The report can be selected by clicking on the tab and closed by clicking on the X.
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Parameters

Parameters are useful in creating reports that are more dynamic. The report will query the user for
information and then typically use this in the record selection criteria. A common use of this feature is
date ranges, categories and personnel.

Selection criteria are usually filtered on from within the Lucity modules. The report is then run using
these criteria, and the specific criteria used can be stated in the subtitle. Sometimes, it is helpful to
have the report make the selection. In the steps below, we’ll show you how to set up these selection
parameters in the report.

Date

In general it is best to set up a date range with two parameter fields. The report query will ask the
user to supply a Start Date and an End Date.

1. In this example, export the Summary of Request (ReqSum.rpt) report and call it
LC_ReqSumbDt.rpt.

2. In LC_ReqSumbDt.rpt open Field Explorer > Parameter Fields.
3. Right click on Parameter Fields and select New.

OR

Click on Parameter Fields and then click the new icon & in the Field Explorer toolbar.

=)

Create New Parameter

Mame: Type:

String -]

List of Values: @) Static () Dynamic
Value Field Description Field
[ (Mane) hd (Mane)

If}lnsert o | 4 4 |Actions -

Value Description

Click here to add item

Options:
Option Setting i
Prompt Text Enter My Parameter: | £ |
Prompt With Description Only False M
Default Value
Allow custom values True

Allra mniltinle waliee Falea

[ oK ][ Cancel H Help ]
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4. In the Create New Parameter dialog, include the following:

a. Enter a Name. For our example, we’ve typed Start Date.

b. Select the type of data that the parameter field will be. In our example, we will

choose Date.

Note: There is an option for DateTime which would correspond with our field type
but in the report we have pulled the Date portion out of the field using the Date

formula.

If you had used the DateTime type then the user would have to enter
the irrelevant Time portion of the field each time they ran the report.

c. Under Options the Prompt Text is automatically filled in with Enter (Parameter
Name). This prompting text can be revised by clicking in the box and adding or
subtracting text. (We have added “for Status Date Range”.)

Create New Parameter

===

Mame:

Type:

Start Date

Date

List of Values: (@) Static

Value Field

() Dynamic

Description Field

[ (MNone)

- ] (Mone)

@Insert x | + ¥ |Actions -

Value

Description

Click here to add item |

Options:

Option

Prompt Text

Prompt With Description Only
Default Value

Allow custom values

Allowe multiple values

Allow discrete values

Setting

Enter Start Date for Status Date Range:

False

True
False
True

m | »

d. OK
5. Repeat this procedure for End Date.

ok || cancel

I

Help

There are now two parameter fields (Start Date and End Date) that can be used in the selection

criteria and in a date title.

Note: Even though the parameters have been created, the report will not use them unless

they are put in the selection criteria.
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Record Selection with Parameters
To use your newly defined Date parameters in a report to select records, complete the followings:

1. Click on Select Expert &
2. Click the Status Date Formula (StatDate).
3. Select OK.

" Choose Field =™

Fields:

..... = WKREQ RQ_REC_DT - OK

..... = WKREQ.RG_STAT_DT

..... == WKREQRG_STAT TY [ e
----- ¥4 Location

Help
..... Browse

- 6 o001 (ODEC (RDO))
L] WKREQ

em3 RE_ACCOUNT

m= RQ_ADR_APT

= RQ_ADR_B2

= RQ_ADR_B22

=

RG_ADR_BDG -

4|:|i 3

The dialog displayed below will appear:

rS;IegE:pen:::' - . el X
| estaate [ ew>|
[isanyvalue. v] [ blewss J
. [ Delete |
{ Browse... ]
[ OK ][ Cancel ][ Help ] [ Show Formula >>> ]

4, Select from the drop down boxes the appropriate criteria:

e mm—— el

Select Expert

@5tatDate | <Mew:
[is between st oate) - [ B ]
[l and [ Delete ]
{?End Date} - [ Browse... ]
N
O I [ Cancel ] [ Help ] [ Show Formula === ]
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5. Then, if you would like to view the formula for the Selection Criteria that you have created,
click on Show Formula>>>

- . - - - - I B —
Select Expert = - (=)
EStatDate | <plew=
| formula: ~| {@StatDate} in {?Start Date} to {%End De » [ Mlew... )
[ Delete ]
[ Browse... ]
< 1 | » |
[ QK ] [ Cancel ] [ Help ] [ Hide Formula <<« ]
N
(@) Record Selection () Group Selection [ Formula Editar... ]
{@statDate} in {?Start Date} to {7End Date} " lI

Note: In Crystal Xl there is an option to Set Parameter Order when you right click on
Parameter Fields in Field Explorer. This is the order in which you will be queried. You can
click and drag the parameters (or use the arrows) to the correct order.

-

Parameter Order e S

Change the parameter arder:
* 7

| ;| Report Subtitle
[?] Start Date
[?] End Date

Adding Farameters to the Report Title

Once you’ve added Date parameters to a report, you’ll want to add that data to the title section. This
helps you know which dates are reflected in the report.

» You can manually enter the dates in the Report Subtitle parameter query.
OR

» You can create a Formula to automatically state the dates selected and place in the Title
section.

OR

» You can create a Text Object and bring in the dates.

Formula Option
1. Right click on Formula Fields and select New.

2. Enter a descriptive name. For our example, we’ve typed “Status Date Range Title”.
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3. Select OK, then type in the following:
"Status Dates Between "&{?Start Date}&" and "&{?End Date}

The parameter fields can be selected from the Report Fields.

—

— '
@ Formula Workshop - Formula Editor - Status Date Range Title ' -'-—-;_m

& Save and close [ Save O - || | i | 7 | |
| | | | | | Crystal Symtax | Exceptions Faor Mulls |
i x| X1 Location - |zl --mFuncﬂons
{2 Report Custom Functions Al .21 Page |
-- FR¢ Repository Custom Functions .l ReqDate
EI{:I Formula Fields nr StatDate
| J(J, Location X1 Status Date Range Title

i}} Page z TotReq

¥} ReaDate 7] Report Subtitle

X StatDate ~12] Stat Date

-3 Status Date Range Title -[7] End Date =
(0 SQL Expression Fisids -8 GBAWork001 {ODBC (RDO)) 4
-] Selection Formulas il
[~ Formatting Formulas

b ? "Status Dates Between "&{?5tart Datel&" and "&{?End Date}

4. Now, either remove the Report Subtitle or create some room in the Page Header section to
drag the @Status Date Range Title formula into the Page Header.

Summary of Requests
PReport Subtitle
EitE‘rtatu& Date Range Title

Summary of Requests

Status Dates Between 1/1/2013 and 12/21/2013

Text Object Option
1. Click on Insert Text Object and place below ?Report Subtitle.

2. Type “Status Dates Between and ”
3. Increase the box size to accommodate the addition of the Date parameters.
4

From Field Explorer > Parameter Fields, drag the Start Date in front of “and” and the End
Date behind “and”. Add spaces as needed.

:Summary of Requests

PRepaort Subtitle
LStatus Dates Between {?5tart Date} and {?End Date}
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Summary of Requests

Status Dates Between 1/1/2013 and 12031/2013

Secured Fields (Main Body of Report/

Sometimes, fields should be hidden in reports if the person viewing the report does not have the proper
level of security. This can be done by using parameters and formatting options. Any field can be set up
for security, such as cost, addresses, or phone #’s.

Note: This will only work for fields in the main body of the report. Fields that need to be
hidden in subreports will be addressed in our related workbook, Advanced Crystal 3.

Many cost fields in Work Order reports are set to use the “Hidden” option. Sometimes you may wish to
suppress the fields completely.

The following steps are provided so you can set up your own field security (step 7).

1. From Work > Work Flow Setup > Employees module, export the Employee List Report
(EmployeelList.rpt) and call the new version LC_EmployeeCost.rpt.

Modify the Department text object to Unit Cost.

Add a text object to the right called Overtime Rate.

Remove the EM_DEPT_TY field.

Add from the WKUEMP table the EM_UNIT_C field beneath the Unit Cost heading.

Add from the WKUEMP table the EM_OVERI_C field beneath the Overtime Rate heading.

Right click Parameter Fields and select New.

© N o A W DN

Type in the Name - ViewSecuredFields.

e This is a special parameter field that must have this name “ViewSecuredFields”. When
the report is run within Lucity the security is passed to the report and will not query
the user. If the report is run outside of a Lucity module, in Crystal, then the security
will be queried.

e |If the report is refreshed, it will ask for the parameters again, including the permission
to view the secure fields. At this point you can change the security value the report
will run with.

9. Select the Type > Number and under Options > Discreet Value -True.

10. Click OK.
Field Viewing Options

Field to Show Blank

For a blank field to show up when the user does not have rights to view the secured fields, do
the following:

1. Right click the field that requires suppression (EM_UNIT_C) and select Format Field.
2. Click the Common tab.
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3. Click the formula box ¥=}| next to Suppress.
4. Double click the ViewSecuredFields parameter from the Report Fields.
5. Type “=0".
{?ViewSecuredFields} =0
6. Click Save and close.

7. Click OK

Field to show “Hidden”

For the word “Hidden” to show up when the user does not have rights to view the secured
fields, do the following:

1. Right click in the field that requires suppression (EM_OVERI_C) and select Format
Field.

2. Click the Common tab

3. Click the formula box == next to Display String.
4. Type in:
if {?ZViewSecuredFields}=0 then "Hidden" else "$"& ({WKUEMP.EM_OVERI_C})

Note: The inclusion of the dollar sign is because once the formula brings in the word
“Hidden”, the formula requires the outcome to be text. The field will not allow number
formatting.

Using the “&” for joining is an implied “to text” for the number field. If a “+” had been
used  for  joining, then a conversion would have been necessary
+(totext({WKUEMP.EM_OVERI_C})).

5. Click Save and Close.
6. Click OK

If the user did not have permission to view Employee costs, then because of the field set ups, the Unit
Cost is blank and the Overtime is showing “Hidden”.

Unit Cost Overtime Rate
Hidden
Hidden
Hidden

It would be helpful to make a notation at the bottom of the report to explain why some of the fields
are “Hidden”, such as:

“A Hidden field indicates permission to view the secured field is turned off.”
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logged in User ID and logged in Employee Code - Web Only

For versions 7.4 or later the Logged in User ID and Logged in Employee Code can be brought into the
report straight from Lucity. This information is being brought in from the Employee module in Work
and is set up much like the “ViewSecuredFields” parameter.

» For the User ID, create a new parameter called LOGGEDINUSERID.
» For the Employee Code, create a new parameter called LOGGEDINEMPCODE.

Both parameters are String type fields.

Drag the parameter fields into the report. When the report is run from Lucity, these fields will
populate with the correct Logged in User information.

Static and Dynamic Selections

A pick list of values to use in a report is possible by using parameter fields. An example of this use will
be shown in selecting Categories.

1. From Work > Work Flow Setup > Category, export Category with Problem and Task Report
(CatProbTask.rpt) and save as LC_CatProbTaskCat.rpt.

2. Right click Parameter Fields and choose New.

3. Enter the Name (Category). Beginning with version 2015, Lucity Web will support dynamic
parameter selections but requires a the Name to be that of the specific field. (See Dynamic
Selections)

4. Enter the Type (String).

5. Choose the “List of Values” type. Set up as either a Static Selection or Dynamic Selection.
(Discussed next)

Static Selections
This allows selection from a set list of values for a specific field.

1. Next to “List of Values:” select Static.

2. Under Value Field select CT_BR_TY (This is the Category text field).

. . . L . % Insert
If you want to choose specific Categories to be in your selection list, click Insert .
Click on the down arrow under Value.

Click the Category that you want in your list.

o Ul AW

For each additional Category, click on a blank line, and then click on Click here to add item,
and then click the down arrow for the list.

o If All the Categories should be in the list, click Actions and choose Append all database
values.

o This drop down box is also where you can clear all values in a list.
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7. Under Options you may revise the Prompt Text. It has automatically placed the Name
(Category) after Enter.

8. Under Options place True next to both Allow discreet values and Allow multiple values.

o The True and False options may be changed by clicking on True (or False) which will
cause a drop down of True or False to select from.

9. Click OK.

Create Mew Parameter . I 2.5 J

Name: Type:
i Category 5iring ']

List of Values: @ Static () Dynamic
Value Field Description Field

’EE' CT_BR_TY v] [ (Mone) -

i Lf‘};lnsert MActions =

Value Description

4th Of July Activities
Admin

Adult Sports

Automated Meter Readers
Auiliary Equipment
Badkflow Preventors

Options:
Option Setting

.3

Prompt With Description Only False
Default Value

Allow custom values True
Allow multiple values True

Allrw dierrats wahiee True

lam |

0K ][ Cancel ][ Help

Dynamic Selections
This allows selection from whatever values are in a specific field at the time the user runs the report.

For This option to be used with Web reports, the report needs to be developed in Crystal 2008 or later
and run with the HTML view. Lucity version 2015 Web supports dynamic selection for either HTML or

pdf.
1. Edit the Category parameter. Next to List of Values: select Dynamic.

2. In the Prompt Group Text box enter something helpful so the user knows what field is being
addressed.

3. Under Choose a Data Source, select New.

4. Then Click either Insert or Click here to add item. Select the field in question.
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5. Edit the Prompt text if desired.

6. Select Options
7. OK

P

Create Mew Parameter

Mame: Type:
b Category String
List of Values: () Static (@ Dynamic
Prompt Group Text: Category
Choose a Data Source:
@ Mew Existing
[ Insert X | + ¥
Value Description Parameters
m= T _BR_TY (Mone) Click to create parameter

Click here to add item

Options - Level 1 (CT_BR_TY):

Cption Setting o
Prompt Text Enter Category: =
Sort Order Ascending by Value 1
Prompt With Description Only False |
Allow multiple values True

Allrw dierrete waliee Tris i

[ 0K ][ Cancel H

Help

Note: For Web reports, make sure the Show on (Viewer) Panel option is set for Editable.

Option

Showe an (Viewer) Panel

Setting
Editable

8. For version 2015 or newer Web reports to show a dynamic pick list before the report is run, the
Parameter name will need to match the field that is being selected from.

o InField Explorer > Parameter Fields > Category, right click Category and select

Rename...

o Type in WKCAT.CT_BR_TY

Note: If the parameter had been new then this would have been what was entered in Name
and then the Prompt Text would have been edited to read Enter Category.

Beginning Crystal 2
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Using the Selection Parameter
You must now add this selection criterion to the Select Expert.

{WKCAT.CT_BR_TY} = {?Category}
For version 2015 or later dynamic parameters, it would look like this.
{WKCAT.CT_BR_TY} = {?WKCAT.CT_BR_TY}

When the report is run and the Category parameter is queried, it will appear similar to the following
example.

» Below, we have selected a group of Categories by clicking on Curbs.
Then shift/click on Engineering
Then the > button
Individual Categories can be moved by clicking on the Category and then the > button.
All of the Categories can be selected by using the >> button.

Another helpful way to select Multiple values is selecting the value then holding the control
key(Ctrl) down and selecting additional values, then moving these values over with one click on
the > button.

The Remove and Remove All buttons work with the Selected Values: window.

OK
Category Category
Enter Category:
Available Values: Selected Values:
Conduit Cabling - Curb
Containers (=1 Detention Basins
Culture and Arts o Dry Creek Wastewater Treatment Plant
Curb Engineering
Detention Basins
Dry Creek Wastewater Treatment Plant
Engineering
i
Remove || Remaove All
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Dynamic Cascading FPrompts

A dynamic cascading prompt allows the user to choose first one selection criteria and for this chosen
selection then choosing a second one ...

For a Storm Pump Inspection report a parameter was created to choose a Pump Station and then once
the station was selected then the pumps were selected from a list of pumps associated with the
station.

Edit Parameter: Station/Pump - PN_NUMBER (Cx)
e ——
Mame: Type:
String
List of Values: I:-_:I Static |§| Dynamic
Prompt Group Text: Enter Station and then Pumps

Choose a Data Source:

@) New (@) Existing [ PM_MUMBER. = PI_MUMBER. - Prompt Group -
‘ Insert 9 | + ¥
Value Description Parameters
== PN_NUMEBER. {Mone) [?] Station/Pump - PN_NUMBER.
== PT_NUMBER {Mane) [?] station/Pump - PT_NUMBER

Options - Level 1 (PMN_MNUMBER):

Option Setting ol
Prompt Text Enter Station:

Sort Order Ascending by Value =
Prompt With Description Only False

Allow multiple values False

Allow discrete values True -

[ oK ][ Cancel H Help

The selection criteria within the Select Expert would be set up like this:
{SMPINSP.PI_NUMBER} = {?Station/Pump - PI_NUMBER} and
{SMSTATN.PN_NUMBER} = {?Station/Pump - PN_NUMBER}
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When running the report the following prompt would show up:

Enter Values ﬂ

Enter subtitle text here (not required): Report Subtitle

Enter Station and then Pump(s) Station/Pump - PL_NUMBER/Station/Pump - PN_NUMBER

Enter Station:
2 =]

Enter Pump:

Available Values: Selected Values:

25a
4

Remove || Remove Al |

| ok | cancel |

Farameter Date Formatting for Entry

Crystal expects dates to be entered as yyyy-mm-dd. A client wanted to be able to enter dates mm-dd-
yyyy. To get around the standard Crystal formatting, the date parameters were set up as string fields
instead of date fields.

Edit Parameter: Start Date

Marne: ul=H

List of Walues: (%) 5tatic () Dynamic
walue Figld Description Field
| {Mone) w | {Mone)

@Insert x & & Actions -

Value Description
Click here to add item

Options:

[>

Opkion Setting
Prompt Text Enter Start Date as MM/DD:
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When the parameters were used in the Select Expert they were converted to Date type fields.
Date (WKRESRCE.WR_END_DT}) in [CDate ({?Start Date}) to CDate ({?End Date})]

Note: Later versions of Crystal allow the parameter date entry in the mm-dd-yyyy structure.

Sorting

Sorting is a simple method to view data in your report in a certain order; ascending or descending.
Crystal Reports allows sorts within sorts, each sort reflecting its own sort direction.

If there is grouping in a report (discussed next), the grouping comes first before any field sorting. Many
of the work reports have groupings to deal with duplicate records created in filtering so simple sorting
will not work. Additional sorting results can usually be accomplished with additional groups.

We are going to set up a simple sort within the LC_ReqSum.rpt report. The following steps will set up
a sort on the Category then within Category a sort on the Problem.

Ak
“E

1. Click Record Sort Expert
2. Choose the field to be sorted by. This is typically found in the Report Fields.

o Click on RQ_CAT_TY and move to the Sort Fields box by pressing the > button.
3. Then select the Sort Direction: Ascending or Descending.

4. Repeat this for the RQ_PROB_TY field. Each field’s Sort Direction is independent of the other
fields to be sorted on.

P —_—
[ Record Sort Expert 2 - ™ . w
Available Fields: Sort Fields: -
=&, Report Fields - ;=_ = A - WHREQ.RG_CAT_TY

..... m= WKREQ.RQ_CAT_TY[ | = A - WKREGQ.RG_FROB_TY
----- = WKREQ.RG_FLLW D

----- = WKREG.RG_ID

..... = WKREG.RG_NUMBEF
..... = WKREQ.RG_FROB_T
..... = WKREQ.RG_REC_DT
----- = WKREGQ.RG_STAT_D

----- = WKREQ.RQ_STAT_T Sort Direction:
----- = WKREQ.RQ_X_COOR _ © Ascending
. J— 'u.ll;'rl;u—r\ e .al-u\.nrn .:. Descending |
oK |[ cancel || Hep ||
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Interactive Sorting
To create a report with a choice of sorting, we will export the Summary of Requests (ReqSum.rpt)
report and rename it LC_ReqSumSort.rpt.

1. First we will create a Static parameter formula to list what the sorting choices are. (Sort By)

Edit Parameter: Sort By lé]

Mame: Type:

Sort By | String -

List of Values: @) Static () Dynamic
Value Field Description Field
’ {Mane) - {None)

Li‘}Insert | MActions =

Value Description

Prablem
Status
Click here to add item

Options:
Option Setting |+
Prompt Text Enter Sort By: |E |
Prompt With Description Only Falze [
Default Value
Allow custom values False
Allow multiple values False &2

2. Using Formula Workshop, create a formula (Sort) to use the correct sorting parameter.

If [?5ort By}="Problem” then [WKRE(.RQ PROE TY}
Else if {?5ort By}="Status”™ then {WEREQ.RQ STAT T¥}|

3. Place this formula in the Detail Section.

Summary of Requests
PReport Subtitle

— [ . T B
) Fequest # 4 ecord Date,  Status a

- -
D . [@SortlRa_NUMBER | @RegDatg ROQ_STAT_TY N

RF ; : Total Ftequestsz _ ¥TotReq

4. Use the Format Field option to hide the @Sort formula field by Suppressing.
Format Editor &

Common |Border I Faont I Paragraph I Hyperlink|

Object Mame: Sortl

Tool Tip Text: ﬂ
=

[T read-only [ Lock Pasition and Size

Suppress g

] suppress If Duplicated %
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5. Place the @Sort formula under Sort Fields: in the Record Sort Exper

| Avaiiable Fields:

&
t

Sort Fields:

..... = WKREGQ RG_ID

X1 | ocation
""" %1 ReqDate
| I I ¥4 Sort
----- ¥ StatDate
(| =3
=-E) WKREQ

—_— e

4 - 1 |

..... = WKREQ.RQ_LOC_AP" -

----- = WKREQ.RG_LOC_B2Z 4

GEAWork001 (ODBC (RDC

Preview

= A - @5ort

Sort Direction:
@ Ascending
(7) Descending

The following prompt will appear. The drop down arrow will show the fields to be sorted by.

[ Enter Values

Enter Sort By: Sort By
[Probem ————— |4
Enter a WValue:
IPruhIern
oK || cancel
Summary of Requests
Reguest# Record Date Status Status Date Priority Problem
2008-09991 12/8/2008 MNew Reguest 12/8/2008
2007-01258 1/8/2007 WO Completed 1/2/2007
2002-00015 8/7/2002 MNew Reguest B/7/2009
2002-00021 B8/7/2002 MNew Reguest B/7/2009
2002-00022 8/7/2002 MNew Reguest B/7/2009
2009-00027 8/7/2008 MNew Reguest B/Ti2009
2012-00001 3/8/2012 MNew Reguest 3/8:2012
2007-05272 2/8/2007 MNew Reguest 2/8:2007 Abandoned W aste
2008-035938 11/1/2008 Completed 11/2/2008 Immediate Priority Accident Response
20068-07730 11/27/2008 Completed 11/30/2008 Accident Response
200G-0787E 11/28/2008 Completed 11/30/2008 Accident Response
2008-09895 12/7/2008 Completed 12/21/2008 Accident Response
2007-04571 1/31/2007 MNew Reguest 1/31:2007 Accident Response
2008-04078 11/3/2008 WO Completed 11/11/2008 Immediate Friority Bees In The Box
2008-04113 11/3/2008 WO Completed 1/2/2007 Immediate Priority Bees In The Box
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Crouping

Grouping is a powerful tool and relatively easy to use. It is particularly helpful when creating
summaries or counts.

We are going to add a grouping on Problem to the Summary of Requests report.

1. From Work Requests export the Summary of Requests (ReqSum.rpt) report and rename it
LC_ReqSumProbGr.rpt.

2. Change the Report title. For example, we’ve titled this report: Requests By Problem Report.

3. Select Insert Group 1S . If the field you wish to “Group By” is currently in the report, click on
it to highlight it and then press the Insert Group button. It will automatically be grouped on
the field; however, you may also use the drop down box to select the field to group on

(RQ_PROB_TY).

Common | 0 ptiars |

When the repart iz printed, the records will be sorted and

grouped by:

BSYKFEC R FroE T |
Iin azcending order, j
[~ Use a Formula as Group Sart Order *_'2.

The zection will be printed on any change of;
WEREQ.RO_PROB_TY

E Cancel | Help |
4. Choose any pertinent options.
Commar DD“U”SI

[~ Customize Group Mame Field
% Choose From Existing Field

[= WKREQ.RG_ID =
£ se aFomula as Group Hame =

™ Keep Group Together

[v ‘Repeat Group Header On Each Fage

0k, I Cancel Help

Beginning Crystal 2 23



o Group Header (GH1) and Footer (GF1) sections have been added.
o The Group #1 Name is the field that this report was grouped by.

hequests by Problem Report
“Report Subtitle
F

'__ Pequest # : :HEDEH:I Daté: EE‘rtatu&
GH1 B rﬁrnupﬂ"tﬁ H ame :
0 ] RQ_NUMBER .. @RegDate, ROQ_STAT_TY
GF1
RF . " Total Requests: _#TotReq

Preview

Requests by Problem Report

Reguest # Record Date Status Status Date Priority Problem
2008-05931 12/8/2008 MNew Request 12/8/2008
2007-01258 1/8/2007 WO Completed 1/8/2007
2002-00021 B/T/2002 New Request B/T/2002
2012-00001 3/8/2012 New Request 3/8/2012
2009-00022 B8/7/20089 New Request B/7T/2009
2009-00015 B/7/2002 New Request B/T/2009
2002-00027 B/7/2009 New Request B/T/2009

Abandoned Waste

2007-05272 2/8/2007 MNew Reguest 2/8/2007 Abandoned W aste
Accident Response

2008-09835 12/7/2008 Completed 12/21/2008 Accident Response

2007-04571 1/31/2007 Mew Reguest 1/31/2007 Accident Response

2008-03598 11/1/2008 Completed 11/2/2008 Immediate Priority Accident Response

2008-07878 11/28/2008 Completed 11/30/2008 Accident Response

2008-07730 11/27/2008 Completed 11/30/2008 Accident Response

BeesIn The Box

2005-09375 WO Completed Immediate Priority Bees In The Box
2008-11825 3 WO Completed Immediate Priority Bees In The Box
2007-04080 WO Completed Immediate Pricrity Bees In The Box
2007-08165 WO Completed Immediate Priority Bees In The Box

The Problem is now being shown twice, once as a Group Header and again as a column, so we will
eliminate the Problem column.

We will create a separate section with the column headings (Page Header b) because there is
currently no room to fit Problem above Request #. (next page)
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5. On the left-hand ruler, find the spot where you want the break to occur. It should appear just
above the column titles.

o Click and hold the mouse over that spot and move the cursor slightly, pull to the right
and release. A new break line is formed. The section with the column titles is Page
Header b (PHb).

Increase the size of Page Header a by dragging down the bottom line of this section.

Drag the Problem column title above Request # in the Page Header a section. Format bold.
Left align the Group #1 Name field to the Problem text box.

Delete the Problem field (RQ_PROB_TY).

O 00 N o

10. The address formula could be moved over (left side at 6”).
11. In File > Page Setup..., change from Landscape orientation to Portrait.

12. Adjust lines and Page Header fields to fit in the Portrait orientation.

Requests By Problem Report
BReport Subtitle

:Prc-blem :
F T T r = r T . L
PHE . Pequest # . [Record Datg, Status . . Status Dats, Priority . pddress
GH1 B Group #1 Name :
D ] RQ_MUMEBER .. @RegDats, RQ_STAT_TY . . (@GStsiDsts, RQ_PRTY_TY . @ Location
GF1
RF - : Total Ftequestsz . #TotReq ,
Preview
Requests By Problem Report 2272014
2:44 FM
Problem
Request # Record Date Status Status Date Priority Address
2006-09981 12/8/2008 Mew Request 12/8/2008 76 E CIVIC CENTER DR
2007-01256 1/8/2007 WO Completed 1/8/2007
2002-00022 8/7/2009 Mew Request 8/7/2009
2008-00015 B/T/2008 Mew Request 8/7/2009
2008-00021 8/T/2008 Mew Request 8/7/2009
2002-00027 8/7/2009 Mew Request 8/7/2009
2012-00001 1/9/2013 W O Completed £/28/2013
2014-00001 1/21/2014 Assigned to WO 1/21/2014
Abandoned Waste
2007-06272 2/8/2007 Mew Request 2/6/2007 126 W CULLUMBER AVE
Accident Response
2008-09835 12/7/2008 Completed 12/21/2008
2007-04571 1/21/2007 Mew Request 1/31/2007
2008-03598 11/1/2008 Completed 11/2/2008 Immediate Priority M GREENFIELD RD
2008-07E78 11/28/2006 Ceompleted 11/20/2008
2008-07720 11/27/2006 Ceompleted 11/20/2008

Beginning Crystal 2 25



Note: Like when Sorting, Grouping can be nested; a Group within a Group. If multiple
groups had been used then they could be switched around by clicking and dragging on the
sections.

Summaries

You may want to know the total count of each individual group. The summary option can be used for
this purpose. Continue with the LC_ReqSumProbGr.rpt report.

1. Click on the field that you wish to count. (RQ_NUMBER)

2. Select Insert Summary L  The Insert Summary dialog will appear:

e The field to summarize (RQ_NUMBER) should already be in the field to summarize.
3. Select the type of Summary (Count).
4. Choose the summary location (Group#1) and click OK.

Insert Summary ﬁ

Choose the field to summarize:

= WKREQ.RQ_NUMBER -|
Calculate this summary:
[Courrt - ]

Summary location

= Group #1: WKREQ RQ_PROB_TY - A -|

Insert Group... ]

Options
[ Show as a percentage of
Grand Tatal: Count of B2_MNUMBER

Summarize across higrarchy

| oK || cancel || Hebp

There is now a subtotal for each Problem group.

o You may want to add some lines and make the group subtotal bold for easier reading.
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rRequests by Problem Report
PReport Subtitle

[3 -
Froblem "

13 G T T r T .. =T 3
Reguest # , [ecord Date, Status L, . Status Date Priority , pddress "
Group #1 Hame :

RQ_MUMBER .. @ReqDaty, RQ_STAT_TY . . @StatDats, RQ_PRTY_TY . [@Location .

=

Problem Total; Countof W]

L

Total Requests! #TotReq

Preview
Problem
Request # Record Date Status Status Date Priority Address
2008-09991 12/8/20086 New Reguest 12/8/2008 75 E CIVIC CENTER DR
2007-01258 1/2/2007 WO Completed 1/2/2007
2002-00021 8/7/2009 New Reguest 8/7/2009
2012-00001 3/6/2012 New Request 3/8/2012
2002-00022 8/7/2009 New Reguest 28/7/2009
2002-00015 8/7/20089 New Regquest 2/7/200%9
2002-00027 8/7/2009 New Reguest 28/7/2009

Problem Total: 7
Abandoned W aste

2007-05272 2/8/2007 MNew Reguest 2/8/2007 126 W CULLUMBER AVE
Problem Total: 1

Accident Response

2008-03695 12/7/20086 Completed 12/21/2006

2007-04571 1/31/2007 HNew Reguest 1/31/2007

2008-03593 11/1/20086 Completed 11/2/2008 Immediate Priority M GREENFIELD RD

2008-07878 11/28/2008 Completed 11/30/2006

2008-07730 11/27/2008 Completed 11/30/20086

Problem Total: 5

The report already has a Grand Total but if you needed to create one you could repeat the process and
choose Grand Total (Report Footer) in the Summary location box. The summaries will automatically be
dropped into the report wherever Crystal seems to think it should go. Click and drag the field and
reformat it to fit your needs.

Running Totals

The Running Totals feature is used to add a list of numbers cumulatively. The various options offered
within the Running Total dialog have rendered the use of variables (discussed in later documents)
obsolete in some cases.

In this example we will create a count on the number of Work Orders per Category.

1. In the Work Order module export the Work Order Summary Report (WOSum.rpt) and rename
it LC_WOSumRunTot.rpt.

Create a new group on Category (WO_CAT_TY).
Shift the Category group to Group 1 by clicking and dragging it into position.

Delete the Category Column.

g AN W N

Move the Main Task and Address columns to the left about 1 2 inches.
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6. Change the Report title to “Work Orders By Category Report”.

7. Within Field Explorer, right click Running Total Fields and select New. The Create Running
Total Field dialog will appear.

8. Type in a name for the Running Total Name (i.e. WO Count).

9. Choose the Field to Summarize (WO_NUMBER).

10. Choose the Type of summary (count).

11. Choose how the report will Evaluate the Work Order Number field.

o On change of group - WO_NUMBER

12. Choose when to Reset.
o On change of group - WO_CAT_TY
13. Then, click OK.

Create Running Total Field

Available Tables and Fields:

:
:

=&, Report Fields

WEORDER. WO _ACTM_TY
WEORDER. WO _CAT_TY
WEKORDER. WO _ID
WHORDER.. WO _MNUMEBER
WHKORDER. WO _STAT_DT
WHKORDER. WO _STAT_TY
WHKORDER.WO_TOTCOST
StatusDate

=& GBAWork002 (ODEC (RDO))

WEORDER.
WKORDERLOC
WERESRCE

; WETMPSEST
: WHWOASSET
! WHWOEVENTS

H

WEWOTSK

14. Add a text object for a column header (No. WO) just to the right of Address.

Eiddress .

Ho. WO’

Beginning Crystal 2

Running Total Mame:
Summary
Field to summarize

Type of summary

Evaluate

() For each record

(7) On change of field
i@ On change of group
() Use a formula
Reset

(71 Newer

() On change of field
@ 0On change of group

(7) Use a formula

WO Count

WHORDER. WO _NUMBER

count

[Gmup £2: WKORDER.WO_NUME

=

| Group #1: WKORDER.WO_CAT_ |

=]

Ok

l [ Cancel

J[ nee |
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15. Drag the Running Total formula (WO Count) under the “No. WO” column header into the
Group footer 1 (GF1) section.

e The Running Total formula has a pound sign “#” in front to distinguish it as a Running
Total type field (#WOCount).

Address [ HNo. WO’

VS
A

. Locations.rot :

PP

_ WO Count

L

We will now add a count of Work Orders greater than $200 per Category. This will use a formula for
evaluation.

16. Within Field Explorer, right click Running Total Fields and select New. The Create Running
Total Field dialog will appear.

17. Type in a name for the Running Total Name (WOCount>200).
18. Choose the Field to Summarize (WO_NUMBER).
19. Choose the Type of summary (distinct count).
20. Choose how the report will Evaluate the WO_NUMBER (Use a Formula).
o Type in the following formula:
{WKORDER.WO_TOTCOST}>200
Choose when to Reset (On Change of Group- WO_CAT_TY).
21. Then, click OK.
5I

Available Tables and Fields:

=5 Report Fields

LB WKORDER, WO_ACTI_TY
T WKORDER WO_CAT_TY
= WKCORDER. WO_ID

== WKORDER. WO _NUMBER
== WKORDER.WO_STAT_DT
== WKORDER, WO_STAT _TY
T WKORDER, WO _TOTCOST
¥ StatusDate

=~ GBAWarkDO1 (ODEC (RDO)
(-] WKORDER
WHKORDERLOC
WKRESRCE

WKTMPSEST

Running Total Mame:

| WOCount =200
Summary

- | Field ko summarize

Type of summary

I WEORDER. WO _MUMEBER

Idistinct count j

Evaluate

" For each record

LI " on change of field I

" on change of group I j

WEWORSSET
WKW OEVENTS
-] WKWOTSK

Beginning Crystal 2

" Never
" on change of field

' on change of group

" Use a Formula

[sroup #1: WKORDER.WO_CaT_ 7 |

x=-2|

o]

Cancel | Help |
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22. Create a new column title (No. WO > $200) and place it to the left of Total Cost.

23. Drag the Running Total formula (WOCount>200) into the Group Footer 1 (GF1) section under
the “No. WO >$200” column header.

Work Orders By Category Report _ L PmtDatg
hReport Suntitle Y PrntTmd
- t'uo # N Status . Status Date . Main Task : Address . Ho. WO No. WO >$200 *Total Cost

GH1 ) proupm Name
GHZ . Qféﬂ’,p’/&’r%’//////////////////////////////////////////////////////////////////////////////////////
D . //////////////////////////////////////////////////////////////////////////////////////////////////
GF2za . Wo_NUMBER D Wo sTAT TY StatusDste WO _ACTN_TY Locations.rot I . @wocesi

GFn //////////////////////////////////////////////////////////////////////////////////////////Xzﬁﬂfé@
GF1
RF

" #WO Count [Count-200

N @GrToi
Preview
Work Orders By Category Report BABR2014
3:09 PM
Wo # Status Status Date Main Task Address Ho. WO No. WO >§200 *Total Cost
Auxiliary Equipment
2002-00041 New W ork Order 8/7/2009 Emergency Response 202 ELAKELDR 524523
1 1

Backflow Preventors
2008-02311 Complete 11/3/2008 Routine Maintenance 514 84

Work Order Reports

The importance of using Running Totals and Grouping can’t be stressed enough for
Work Order reports that have summaries.

This is only an issue if the report is to be run with a filter on any field that is normally a grid (child)
type field such as Location, Task or Resource. Never assume the report will not be used with a filter.

Importance of Grouping

In the previous report the Work Order information was placed in the Work Order Number Group Footer
section.

If the information had been put in the Detail section and the report run with a filter on a field that is

normaly a grid type field, then the information in the Detail section would show up as many times as
the filter is true.

An additional Category Cost is added using the Insert Summary tool to help illustrate the point.

Work Orders By Category Report D pmtoed]
Repart Subtitle ™[ PrintTin§
- tvo- # . ;status j Status Date | Main Task j Address . lo. WO No. WO >$200 “*Total Cost
GH1 . Qroup\‘.ﬂ Name
H . MM&%&W//////////////////////////////////////////////////////////////////////////////////////
. Wo MuMBER T Wo_sSTAT_TY StatusDats WO _ACTN_TY Locations.rot . @WoCast

T
GFb [ e e e e
GF1
RF

T #WOCouni [ount=200 ) _TOTCOST
@GrTof
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In the previous example the WO# 2009-00041 record has the following Resources:

Resources
Group | Type | Resource | Resource Text | IJOk | [Ihitg | Cogt |
Employes 345 OTTOJOMES 400 125
Equipment P/U0490  Pw/UI0490 CHEVROLET SILVERADO Hours 400 1118
Employes 332 WILLIS HEMDRI= Hours 300 108

If a Lucity filter had been created to view records that had Employees as Resources (WR_RTYP_CD=1)
then the report run in Lucity with this filter, the previous report would have looked like this:

Wo # Status Status Date Main Task Address No. WO HNo. W0 >5$200 *Total Cost

Auxiliary Equipment

2009-00041 Mew Work Order 8/7/2009 Emergency Response 202 ELAKEDR 524523

2009-00041 Mew Work Order 8/7/2008 Emergency Response 202 ELAKEDR 324523
1 2 490.46

The WO# 2009-00041 record shows up twice because there are two Employees in the Resource section.

The Total Cost and No. WO >$200 for the Auxiliary Equipment is also double. The No. WO value is
correct because we said to evaluate on change of group (WO_NUMBER).

Importance of Running lotals

The way the report is currently set up, the information is placed in the Work Order Number Group
Footer section and the Total Cost Field is in a formula with variables (discussed in later documents).
The Cost field could have been brought in simply as a field (WO_TOTCOST). Running Totals could have
been used to total the cost for both the Category Group and the Report Total.

The following example shows the importance of the Running Total E
when the report is run with a filter of a field from a grid.

instead of the Summary z

The information is placed in the Work Order Number Group Footer section so it only shows once.

Work Orders By Category Report R
SReport Subtitle ) . Print Timg
'__ tﬂ.l'O # : :'Etatus : :Status Date | i."lain Task : Eﬂlddress : I:‘iummaryr ﬂhunning Total "’Total Cosi
GH1 . Group #1 Name
GHZ . .&tﬁd)ﬂ’m’/ﬂf/Z/W//////////////////////////////////////////////////////////////////////////////////////
D . ’/////////////////////////////////////////////////////////////////////////////////////////////////
GFZa . wo MUMBER TWo_sTAT_TY @Smusoatg wo ACTH_TY L Locations. rot B Wo_ TDT...DST
GF1 . . S5umof WKORDER.WO_TOTCOST ., #CailTo}

The total cost for the Category is shown with a simple summary in Bold and as a Running Total formula
in Italic.

wo % Status Status Date Main Task Address Summary Running Total *Total Cost

Auxiliary Equipment

2009-00041 New Work Order &8/7/2008 Emergency Response 202 ELAKE DB 24523
490.46 24522
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Concatenate Fields

Multiple fields can be joined together in a single formula as opposed to bringing all of the fields in
separately.

This might be useful for names or address. The concept is simple; however, if any of the fields in a
simple “+” type formula are empty, the formula would show up as blank.

The null fields need to be addressed as follows:

In the current Work Order Detail Report (WODetail.rpt) the Billing information looks like this:

. . " Billing
- - LBiIIe(IPartyJ - - — -
::ustomer 1D: *WD_EII:LISTID . ] Customer Huml:-er:* WO_BCUSTHND .
Customer Name: W 0_BFIRST : [_astuame-:- D o_pLasT
FA(I(Iress: 4I1_|1|'D_EIADDR1 .
Preview
Billing
Billed Party
Customer ID: Customer Humber:
Customer Hame: Caral Last Hame: Smith
Address: 122 Oak

We can create a formula to join the First and Last Names. In the example we will create a formula
called Name:

In the Formula Workshop the formula can be typed in manually or parts can be brought in from the
various workshop sections (Field, Function or Operator). “If Then Else” can be brought from Operators
> Control Structure. “Is Null” can be brought in from Functions > Print State.

(If IsNull({WKORDER.WO_BFIRST}) Then " " Else {WKORDER.WO_BFIRST})&" "&
(If IsNull({WKORDER.WO_BLAST}) Then " " Else {WKORDER.WO_BLAST})

This would change the format to:

- - 3 Billing ;
LBiIIecI Party ;
Customer ID: 1ErtrD_El|:U STID ) Customer Humber:” jW0_BCUS
E:ustomer Hame: : Mam e .
LA{I-[Iress: Jiwa_BADDRA ) ) . o
Preview
Billing
Billed Party
Customer ID: Customer Humlyer:
Customer Hame: Carol Smith
Address: 122 Dak
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Note: The ampersand (&) operator may be used instead of the plus sign for string
concatenation. This will perform an implicit conversion when the formula uses mixed data

types.

“Total $” & {WKORDER.WO_TOTCOST} instead of “Total $”+ cstr({(WKORDER.WO_TOTCOST})

Address Formula

Another common usage of concatenated fields is the Address field. Any time a record shows the
address as multiple parts ADR_BDG and ADR_DIR then this is a field that uses the address set up in the
General section of Lucity. It should be brought into a report as a concatenated formula.

The Work Order Location Address is as follows:

(If isNull ({WKORDERLOC.WL ADR BDG})then "" else Trim (TcText ({WKCRDERLOC.WL ADR BDG},0,"","")))+" "+
(If isNull ({WKORDERLOC.WL ADR B2})then "" else Trim ({WEORDERLOC.WL ADR B2}])+" "+
(If isNull ({WKORDERLOC.WL ADR DIR})then "" else Trim ({WKCRDERLCC.WL ADR DIR}))+" "+
(If isNull ({WKORDERLOC.WL ADR PT})then "" else Trim ({WEORDERLOC.WL ADR PT}])+" "+
Trim ({WEORDERLOC.WL ADR STR})+" "+
(If isNull ({WKORDERLOC.WL ADR TY¥}) then "" else Trim ({WKORDERLOC.WL ADR TY¥}))+" "+
(If isNull ({WKORDERLOC.WL ADR SFX}) then "" else Trim({WKORDERLOC.WL ADR SFX}))+" "+
(If isNull ({WKORDERLOC.WL ADR APT}) then "" else Trim({WKORDERLCC.WL ADR RFT}))

A null Street Name is not addressed because we do not want to see the formula if there is no Street
Name.

Notes:
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